$re = '/\b(\(?0?\d{2}\)?)?\s?9[\s\-]?\d{4}[\s\-]?\d{4}\b/m';
$str = 'O meu numero de telefone é 991234567 e não mudou
O meu numero de telefone é 11991234567 e não mudou
O meu numero de telefone é 11 99123 4567 e não mudou
O meu numero de telefone é 11 9 9123 4567 e não mudou
O meu numero de telefone é (11)991234567 e não mudou
O meu numero de telefone é (11) 9 9123 4567 e não mudou
O número 3393333333333333 não é um numero valido
O número 22 2 2222 2222 não é um numero valido
O meu numero de telefone é 9 9123-4567 e não mudou
O meu numero de telefone é 11 99123-4567 e não mudou
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);