use strict;
my $str = 'O meu numero de telefone é 991234567 e não mudou
O meu numero de telefone é 11991234567 e não mudou
O meu numero de telefone é 11 99123 4567 e não mudou
O meu numero de telefone é 11 9 9123 4567 e não mudou
O meu numero de telefone é (11)991234567 e não mudou
O meu numero de telefone é (11) 9 9123 4567 e não mudou
O número 3393333333333333 não é um numero valido
O número 22 2 2222 2222 não é um numero valido
O meu numero de telefone é 9 9123-4567 e não mudou
O meu numero de telefone é 11 99123-4567 e não mudou
';
my $regex = qr/\b(\(?0?\d{2}\)?)?\s?9[\s\-]?\d{4}[\s\-]?\d{4}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}