// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\(?0?\d{2}\)?)?\s?9[\s\-]?\d{4}[\s\-]?\d{4}\b").unwrap();
let string = "O meu numero de telefone é 991234567 e não mudou
O meu numero de telefone é 11991234567 e não mudou
O meu numero de telefone é 11 99123 4567 e não mudou
O meu numero de telefone é 11 9 9123 4567 e não mudou
O meu numero de telefone é (11)991234567 e não mudou
O meu numero de telefone é (11) 9 9123 4567 e não mudou
O número 3393333333333333 não é um numero valido
O número 22 2 2222 2222 não é um numero valido
O meu numero de telefone é 9 9123-4567 e não mudou
O meu numero de telefone é 11 99123-4567 e não mudou
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}