import Foundation
let pattern = #"\b(\(?0?\d{2}\)?)?\s?9[\s\-]?\d{4}[\s\-]?\d{4}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
O meu numero de telefone é 991234567 e não mudou
O meu numero de telefone é 11991234567 e não mudou
O meu numero de telefone é 11 99123 4567 e não mudou
O meu numero de telefone é 11 9 9123 4567 e não mudou
O meu numero de telefone é (11)991234567 e não mudou
O meu numero de telefone é (11) 9 9123 4567 e não mudou
O número 3393333333333333 não é um numero valido
O número 22 2 2222 2222 não é um numero valido
O meu numero de telefone é 9 9123-4567 e não mudou
O meu numero de telefone é 11 99123-4567 e não mudou
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)