using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!Hello\b)\S(?:.*\S)?$";
string input = @"test
test
test
Hello
Hello
Hello
Hello
Hell
H
thisis a test
Hello, this is a test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}