import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!Hello\\b)\\S(?:.*\\S)?$";
final String string = "test\n"
+ " test\n"
+ "test \n"
+ "Hello\n"
+ " Hello \n"
+ " Hello\n"
+ "Hello \n"
+ "Hell\n"
+ "H\n\n"
+ "thisis a test\n"
+ "Hello, this is a test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}