re = /\b(\w)/m
str = ' chedilpakkam, tiruvallur,chedilpakkam, tiruvallur
ch edilpakkam,tiruvallur, chedilpakkam,tiruvallur
'
subst = '($1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result