# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\d+];(*SKIP)(*F)|(;)/[0]\1/gm;t' <<< "Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.);Simmons, AJ(Simmons, A. J.);Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)[3]"