use strict;
my $str = 'Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.);Simmons, AJ(Simmons, A. J.);Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)[3]';
my $regex = qr/\[\d+];(*SKIP)(*F)|(;)/mp;
my $subst = '[0]\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";