re = /\[\d+];(*SKIP)(*F)|(;)/m
str = 'Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.);Simmons, AJ(Simmons, A. J.);Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)[3]'
subst = '[0]\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result