package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\d+];(*SKIP)(*F)|(;)`)
var str = `Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.);Simmons, AJ(Simmons, A. J.);Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)[3]`
var substitution = "[0]\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}