const regex = /\[\d+];(*SKIP)(*F)|(;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\d+];(*SKIP)(*F)|(;)', 'gm')
const str = `Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.);Simmons, AJ(Simmons, A. J.);Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)[3]`;
const subst = `[0]\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);