using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[+@:]|\bAT(?!M))\s*([A-Z]+(?:\s+[A-Z]+)*)";
string input = @"$ $ $ +YBL PATAUDI CHOWK \ $
$ $ -ATM CASH 83181 + MAIN BHAWANA ROAD NEW DELHI $
$ $ [5839/P1TNDE06/+RAGHUBARPURA $
$ MAXIMUMOUTFITS PRIVATE LIMITED } $ ATDELHIIN- $ $ /5631 $
$ ATM CASH-N4077800-+SPRINGFIELDCOLONYFFAR IDABADHRIN-04/06/18 $ /5631 ( $ $ VERIFICATION $""))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}