const regex = /(?:[+@:]|\bAT(?!M))\s*([A-Z]+(?:\s+[A-Z]+)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[+@:]|\\bAT(?!M))\\s*([A-Z]+(?:\\s+[A-Z]+)*)', 'gm')
const str = `\$ \$ \$ +YBL PATAUDI CHOWK \\ \$
\$ \$ -ATM CASH 83181 + MAIN BHAWANA ROAD NEW DELHI \$
\$ \$ [5839/P1TNDE06/+RAGHUBARPURA \$
\$ MAXIMUMOUTFITS PRIVATE LIMITED } \$ ATDELHIIN- \$ \$ /5631 \$
\$ ATM CASH-N4077800-+SPRINGFIELDCOLONYFFAR IDABADHRIN-04/06/18 \$ /5631 ( \$ \$ VERIFICATION \$"))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}