re = /(?:[+@:]|\bAT(?!M))\s*([A-Z]+(?:\s+[A-Z]+)*)/m
str = '$ $ $ +YBL PATAUDI CHOWK \\ $
$ $ -ATM CASH 83181 + MAIN BHAWANA ROAD NEW DELHI $
$ $ [5839/P1TNDE06/+RAGHUBARPURA $
$ MAXIMUMOUTFITS PRIVATE LIMITED } $ ATDELHIIN- $ $ /5631 $
$ ATM CASH-N4077800-+SPRINGFIELDCOLONYFFAR IDABADHRIN-04/06/18 $ /5631 ( $ $ VERIFICATION $"))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end