package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` spk:(rt722) spk:(rt1320)`)
var str = `HDA:8086281d,80860101,00100000 cfg-amp:2 hs:rt722 spk:rt722 spk:rt1320`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}