$re = '/ spk:(rt722) spk:(rt1320)/';
$str = 'HDA:8086281d,80860101,00100000 cfg-amp:2 hs:rt722 spk:rt722 spk:rt1320';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);