re = / spk:(rt722) spk:(rt1320)/
str = 'HDA:8086281d,80860101,00100000 cfg-amp:2 hs:rt722 spk:rt722 spk:rt1320'
# Print the match result
str.match(re) do |match|
puts match.to_s
end