import Foundation
let pattern = #" spk:(rt722) spk:(rt1320)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"HDA:8086281d,80860101,00100000 cfg-amp:2 hs:rt722 spk:rt722 spk:rt1320"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}