const regex = / spk:(rt722) spk:(rt1320)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' spk:(rt722) spk:(rt1320)', '')
const str = `HDA:8086281d,80860101,00100000 cfg-amp:2 hs:rt722 spk:rt722 spk:rt1320`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}