import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfunc_name\\([^\\s,=]+(?:=[^\\s,=]+)?(?:,\\h*[^\\s,=]+(?:=[^\\s,=]+)?)*(?=\\))";
final String string = "func_name(a, b=1)\n"
+ "func_name(g=5, k=7)";
final String subst = "$0, c=2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}