$re = '/\bfunc_name\([^\s,=]+(?:=[^\s,=]+)?(?:,\h*[^\s,=]+(?:=[^\s,=]+)?)*(?=\))/m';
$str = 'func_name(a, b=1)
func_name(g=5, k=7)';
$subst = "$0, c=2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;