import Foundation
let pattern = #"\bfunc_name\([^\s,=]+(?:=[^\s,=]+)?(?:,\h*[^\s,=]+(?:=[^\s,=]+)?)*(?=\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
func_name(a, b=1)
func_name(g=5, k=7)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0, c=2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)