const regex = /\bfunc_name\([^\s,=]+(?:=[^\s,=]+)?(?:,\h*[^\s,=]+(?:=[^\s,=]+)?)*(?=\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfunc_name\\([^\\s,=]+(?:=[^\\s,=]+)?(?:,\\h*[^\\s,=]+(?:=[^\\s,=]+)?)*(?=\\))', 'gm')
const str = `func_name(a, b=1)
func_name(g=5, k=7)`;
const subst = `$0, c=2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);