use strict;
my $str = 'func_name(a, b=1)
func_name(g=5, k=7)';
my $regex = qr/\bfunc_name\([^\s,=]+(?:=[^\s,=]+)?(?:,\h*[^\s,=]+(?:=[^\s,=]+)?)*(?=\))/mp;
my $subst = '$0, c=2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";