package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}[A-Za-z]{2}$`)
var str = `Valid from
Zipcode from
0000AA
1798AA
8900AA
9167aa
Valid from
Zipcode to
1797zz
8899ZZ
9166ZZ
9999ZZ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}