re = /^\d{4}[A-Za-z]{2}$/m
str = 'Valid from
Zipcode from
0000AA
1798AA
8900AA
9167aa
Valid from
Zipcode to
1797zz
8899ZZ
9166ZZ
9999ZZ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end