import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4}[A-Za-z]{2}$";
final String string = "Valid from\n"
+ "Zipcode from\n"
+ "0000AA\n"
+ "1798AA\n"
+ "8900AA\n"
+ "9167aa\n\n"
+ "Valid from\n"
+ "Zipcode to\n"
+ "1797zz\n"
+ "8899ZZ\n"
+ "9166ZZ\n"
+ "9999ZZ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}