#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(type:: Coffee Shop)([\S\s]*?)(address::)(.*)"
Local $sString = "- Perk Cafe" & @CRLF & _
"type:: Coffee Shop" & @CRLF & _
"address:: 123 Main St." & @CRLF & _
"serves_food:: Yes" & @CRLF & _
"" & @CRLF & _
"- Daily Boo" & @CRLF & _
"type:: Thee Shop" & @CRLF & _
"address:: 10 Broadway" & @CRLF & _
"serves_food:: No" & @CRLF & _
"" & @CRLF & _
"- Daily Joe" & @CRLF & _
"type:: Coffee Shop" & @CRLF & _
"serves_food:: No" & @CRLF & _
"address:: 10 Broadway" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1$2street_address::$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)