package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(type:: Coffee Shop)([\S\s]*?)(address::)(.*)`)
var str = `- Perk Cafe
type:: Coffee Shop
address:: 123 Main St.
serves_food:: Yes
- Daily Boo
type:: Thee Shop
address:: 10 Broadway
serves_food:: No
- Daily Joe
type:: Coffee Shop
serves_food:: No
address:: 10 Broadway
`
var substitution = "$1$2street_address::$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}