# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(type:: Coffee Shop)([\S\s]*?)(address::)(.*)"
test_str = ("- Perk Cafe\n"
"type:: Coffee Shop\n"
"address:: 123 Main St.\n"
"serves_food:: Yes\n\n"
"- Daily Boo\n"
"type:: Thee Shop\n"
"address:: 10 Broadway\n"
"serves_food:: No\n\n"
"- Daily Joe\n"
"type:: Coffee Shop\n"
"serves_food:: No\n"
"address:: 10 Broadway\n\n\n")
subst = "$1$2street_address::$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.