$re = '/(type:: Coffee Shop)([\S\s]*?)(address::)(.*)/';
$str = '- Perk Cafe
type:: Coffee Shop
address:: 123 Main St.
serves_food:: Yes
- Daily Boo
type:: Thee Shop
address:: 10 Broadway
serves_food:: No
- Daily Joe
type:: Coffee Shop
serves_food:: No
address:: 10 Broadway
';
$subst = "$1$2street_address::$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;