import Foundation
let pattern = #"(type:: Coffee Shop)([\S\s]*?)(address::)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
- Perk Cafe
type:: Coffee Shop
address:: 123 Main St.
serves_food:: Yes
- Daily Boo
type:: Thee Shop
address:: 10 Broadway
serves_food:: No
- Daily Joe
type:: Coffee Shop
serves_food:: No
address:: 10 Broadway
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2street_address::$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)