#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b\d{6}:.*?(?=\s*(?:\d{6}:|$))"
Local $sString = " 610640: 168 hours 610835: till next day 14:00 617041: 168 hours 611486:720 hours " & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)