use strict;
my $str = ' 610640: 168 hours 610835: till next day 14:00 617041: 168 hours 611486:720 hours
';
my $regex = qr/\b\d{6}:.*?(?=\s*(?:\d{6}:|$))/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";