import Foundation
let pattern = #"\b\d{6}:.*?(?=\s*(?:\d{6}:|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
610640: 168 hours 610835: till next day 14:00 617041: 168 hours 611486:720 hours
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)