import re
regex = re.compile(r"\b\d{6}:.*?(?=\s*(?:\d{6}:|$))", flags=re.MULTILINE)
test_str = (" 610640: 168 hours 610835: till next day 14:00 617041: 168 hours 611486:720 hours \n")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)