re = /\b\d{6}:.*?(?=\s*(?:\d{6}:|$))/m
str = ' 610640: 168 hours 610835: till next day 14:00 617041: 168 hours 611486:720 hours
'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result