using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-{3}|[+]{3})$[^\1]*?^\1$";
string input = @"---
title: 'Visual Spell Check'
categories: docs
# parent: Docs
nav_order: 4
---
# Visual Spell Check
View the spell checking results in the document being checked.
## Command: `check` - Quick Visual Check
Do a quick visual check of a file. This is a great way to see which text is included in the check.
```sh
cspell check <filename>
```
It will produce something like this:

### Tip for use with `less`
To get color in less, use `--color` and `less -r`
```sh
cspell check <filename> --color | less -r
```
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}