import re
regex = re.compile(r"^(-{3}|[+]{3})$[^\1]*?^\1$", flags=re.MULTILINE)
test_str = ("---\n"
"title: 'Visual Spell Check'\n"
"categories: docs\n"
"# parent: Docs\n"
"nav_order: 4\n"
"---\n\n"
"# Visual Spell Check\n\n"
"View the spell checking results in the document being checked.\n\n"
"## Command: `check` - Quick Visual Check\n\n"
"Do a quick visual check of a file. This is a great way to see which text is included in the check.\n\n"
"```sh\n"
"cspell check <filename>\n"
"```\n\n"
"It will produce something like this:\n"
"\n\n"
"### Tip for use with `less`\n\n"
"To get color in less, use `--color` and `less -r`\n\n"
"```sh\n"
"cspell check <filename> --color | less -r\n"
"```\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")