# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:--|-|\\/)cplusplus_([A-z0-9_]+)(?:(?:=|:)((?:\+|-)|(?:[:A-z0-9_]+(?:,[:A-z0-9_]+)*))?)/$1 $2/gm;t' <<< "--cplusplus_polymorphic_class=::MyNamespace::MyClass
-cplusplus_polymorphic_class=::MyNamespace::MyClass
/cplusplus_polymorphic_class:::MyNamespace::MyClass,::OtherNamespace::OtherClass
/cplusplus_polymorphic_class=+
/cplusplus_polymorphic_class=-
"