import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:--|-|\\/)cplusplus_([A-z0-9_]+)(?:(?:=|:)((?:\\+|-)|(?:[:A-z0-9_]+(?:,[:A-z0-9_]+)*))?)";
final String string = "--cplusplus_polymorphic_class=::MyNamespace::MyClass\n"
+ "-cplusplus_polymorphic_class=::MyNamespace::MyClass\n"
+ "/cplusplus_polymorphic_class:::MyNamespace::MyClass,::OtherNamespace::OtherClass\n"
+ "/cplusplus_polymorphic_class=+\n"
+ "/cplusplus_polymorphic_class=-\n";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}