package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:--|-|\/)cplusplus_([A-z0-9_]+)(?:(?:=|:)((?:\+|-)|(?:[:A-z0-9_]+(?:,[:A-z0-9_]+)*))?)`)
var str = `--cplusplus_polymorphic_class=::MyNamespace::MyClass
-cplusplus_polymorphic_class=::MyNamespace::MyClass
/cplusplus_polymorphic_class:::MyNamespace::MyClass,::OtherNamespace::OtherClass
/cplusplus_polymorphic_class=+
/cplusplus_polymorphic_class=-
`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}