$re = '/(?:--|-|\/)cplusplus_([A-z0-9_]+)(?:(?:=|:)((?:\+|-)|(?:[:A-z0-9_]+(?:,[:A-z0-9_]+)*))?)/m';
$str = '--cplusplus_polymorphic_class=::MyNamespace::MyClass
-cplusplus_polymorphic_class=::MyNamespace::MyClass
/cplusplus_polymorphic_class:::MyNamespace::MyClass,::OtherNamespace::OtherClass
/cplusplus_polymorphic_class=+
/cplusplus_polymorphic_class=-
';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;