// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:--|-|\/)cplusplus_([A-z0-9_]+)(?:(?:=|:)((?:\+|-)|(?:[:A-z0-9_]+(?:,[:A-z0-9_]+)*))?)").unwrap();
let string = "--cplusplus_polymorphic_class=::MyNamespace::MyClass
-cplusplus_polymorphic_class=::MyNamespace::MyClass
/cplusplus_polymorphic_class:::MyNamespace::MyClass,::OtherNamespace::OtherClass
/cplusplus_polymorphic_class=+
/cplusplus_polymorphic_class=-
";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}