using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"common([^\.]+)?\.js";
string input = @"common.js
common_somethingelse.js
common.min.js
common.min1.min2.js
common.min1.min2.min3.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}