// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)common([^\.]+)?\.js").unwrap();
let string = "common.js
common_somethingelse.js
common.min.js
common.min1.min2.js
common.min1.min2.min3.js";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}