package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)common([^\.]+)?\.js`)
var str = `common.js
common_somethingelse.js
common.min.js
common.min1.min2.js
common.min1.min2.min3.js`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}