re = /common([^\.]+)?\.js/m
str = 'common.js
common_somethingelse.js
common.min.js
common.min1.min2.js
common.min1.min2.min3.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end