$re = '/common([^\.]+)?\.js/m';
$str = 'common.js
common_somethingelse.js
common.min.js
common.min1.min2.js
common.min1.min2.min3.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);